Configuring EIGRP on all Routers

R1:

R1(config)#router eigrp 100
R1(config-router)#network 10.1.1.0 0.0.0.255
R1(config-router)#network 11.1.1.0 0.0.0.255
R1(config-router)#exit

 

R2: 

R2(config)#router eigrp 100
R2(config-router)#network 10.1.1.0 0.0.0.255
R2(config-router)#network 12.1.1.0 0.0.0.255
R2(config-router)#exit

 

R3: 

R3(config)#router eigrp 100
R3(config-router)#network 12.1.1.0 0.0.0.255
R3(config-router)#exit

 

R4: 

R4(config)#router eigrp 100
R4(config-router)#network 11.1.1.0 0.0.0.255
R4(config-router)#exit

 

Configuring EIGRP Static Neighbors in Cisco

EIGRP (Enhanced Interior Gateway Routing Protocol) is an Enhanced-DVRP (Distance Vector Routing Protocol) that generally uses DUAL (Diffuse Update Algorithm) to find the best path to the destination. Since EIGRP is a Dynamic Routing Protocol, it sends the EIGRP messages (Hello, Update, Query, Reply, Acknowledgement) to a multicast address 224.0.0.10, and it uses this multicast address for discovering the neighbors across the Autonomous System (AS group of routers and networks working under a single administrative domain). However, EIGRP also allows us to change this multicast traffic to unicast traffic by adding Static Neighbors instead of Dynamically discovering them. Using Static Neighbors is useful in cases when the admin wants to limit the multicast traffic across a particular interface or if multicast is not supported. These Static Neighborship formed in EIGRP supersedes the Dynamically formed Neighborship. 

For example, if we enable EIGRP routing for two connected routers,

  • To form Dynamic Neighborship, we can just simply add the connected network using the below command: –
router(config)#router eigrp <AS_number>
router(config)#network <network_IP> <wildcard_mask>
router(config)#exit
  • To create Static Neighborship, we have to first add the network in the EIGRP topology, then configure the static neighbor using its IP and the exit interface of the router.
router(config)#router eigrp <AS_number>
router(config)#network <network_IP> <wildcard_mask>
router(config)#neighbor <ip_add_neighbor> <exit_interface_id>
router(config)#exit

This neighbor command stops sending and receiving any multicast traffic for EIGRP on that exit interface, i.e., if the router is sending unicast traffic to create a Static Neighborship it also wants a unicast reply in return on that interface to successfully create the neighborship.

Similar Reads

Topology:

...

Configuring IP Addresses On Routers:

R1:...

Configuring EIGRP on all Routers:

R1:...

Configure Static Neighborship Between R1 and R2:

Step 1: First, let’s just configure static neighbor on R1 only and see the difference using debugging....

Contact Us